Detailsview itemupdating new values

17-Jun-2017 13:14

But when i set up a breakpoint and read changed Text Box value, it is still the old value( the value before Edit button is pressed).

In other words it is not reading Newly entered value during Edit/Update process. New Values is a collection that holds the new values that were entered.

Refer here: View (and Grid View) don't work properly when not used with a proper datasource. :) you did but what I meant was that you were using this: //Even this Find Control does not help either to read the newly entered Text // Text Box test = (Text Box) dv User Record.

Most notibly, the values dictionaries in the events for updating are not filled. Find Control("address"); whereas, and I think, your detailsview is named dv Record.

Ok, Now I'm sure this was working the other day and I don't think I've changed anything but now it's not working and I can't see anything wrong with the code.

Basically I have a details view with product information in it, when the user clicks edit it goes into edit mode when I change any of the fields and click update it updates but with the old values.

detailsview itemupdating new values-84

I'm new at this and I'm sure I'm overlooking something simple here.The product table is not updating with the new values.I think the problem is to do with the new values from the textbox not being retrieved.Here is my detailsview: I tried adding a label to my page and then once updated Name had been assigned the value of the textbox I tried assigning that value to the label and it printed out the old product name not the one in the textbox.I can't see anything wrong with the code and it's driving me mad. hi, i think you miss something, try to see the table where you save the value of the fields you entered if it change anything, if it change anything, then you have put some code on your SP that retrieves data after the UPDATE code that you have.

I'm new at this and I'm sure I'm overlooking something simple here.The product table is not updating with the new values.I think the problem is to do with the new values from the textbox not being retrieved.Here is my detailsview: I tried adding a label to my page and then once updated Name had been assigned the value of the textbox I tried assigning that value to the label and it printed out the old product name not the one in the textbox.I can't see anything wrong with the code and it's driving me mad. hi, i think you miss something, try to see the table where you save the value of the fields you entered if it change anything, if it change anything, then you have put some code on your SP that retrieves data after the UPDATE code that you have.As when I assign updated Name to Label1 it displays the old product name value and not the one in the textbox.